İçeriğe geç

HPE Comware OS 7 5130 CLI Komutları

5130 HI CLI

[casoyalp-ad wminh=”” wmaxh=”” mminh=”” mmaxh=””]

Comware OS’un son versiyonu olan v.7 sürümlerinde aşağıdaki komutlar ile ihtiyaç duyduğunuz ayarları yapabilirsiniz. Bu komutlar HPE 5130 HI model bir cihazda test edilmiştir.

Comware OS işletim sistemi aslında H3C isimli Çin menşeili bir network cihazları üreticisi olan firmaya ait. HPE ise bu işletim sistemini uzun bir süredir bazı cihazlarında kullanmaktadır. Bu cihazların CLI komutları ve kullanımları ile ilgili bilgileri bölümler halinde aşağıda bulabilirsiniz. Comware 5130

Genel Komutlar

system-view : ayarlarda değişiklik yapabilmek için gereken modu açar, Cisco IOS’in configure terminal’i gibi.

NTP ayarları:

[Switch]clock timezone utc add 03:00:00  (Tükiye GMT+3 olduğu için)
[Switch]clock protocol ntp

[Switch]ntp-service unicast-server 192.168.0.18

[Switch]ntp-service enable

Syslog Ayarları:

[Switch]info-center loghost 10.10.71.118 port 514 facility local0 : syslog sunucusuna (10.10.71.118) belirlediğimiz porttan (514) local0 seviyesinde logların gönderilmesini sağlar

[Switch]info-center loghost source Vlan-interface 71 : sysloga gönderilecek olan logların hangi vlan’ın L3 arayüzünden gönderileceğinin belirlenmesinde kullanılır.

SNMP Ayarları:

[Switch]snmp-agent community read AAA1str  : snmpv2 ve v2c için sadece okuma yetkisine sahip AAA1str isminde bir string oluşturur.

[Switch]snmp-agent community write AAA1str  : snmpv2 ve v2c için sadece okuma yetkisine sahip AAA1str isminde bir string oluşturur.

SNMPv3 ayarları:

[Switch]snmp-agent
[Switch]snmp-agent log all
[Switch]snmp-agent sys-info version all
[Switch]snmp-agent community read <comminity-adı>
[Switch]snmp-agent group v3 <group-adı>  authentication write-view <group-şifresi>
[Switch]snmp-agent usm-user v3 <snmpv3-kullanıcı-adı> <kullanıcı rolü> simple authentication-mode sha <snmp şifre> privacy-mode aes128 <snmp şifre>

[casoyalp-ad wminh=”” wmaxh=”” mminh=”” mmaxh=””]

STP Ayarları:

[Switch]stp global enable : spanning tree protokolünün globalde tüm portlarda açılmasını sağlar.

[Switch]stp instance 0 priority 61440 : STP root olması istenmeyen cihazlarda (kenar anahtarlarda)  girilebilecek bir ayar. Bu komutun girildiği kenar anahtarda priority değeri maksimumda (61440) olacağından, hiçbir zaman STP root olmayacaktır.

[Switch-gigabitethernet-1/0/1]stp edged-port : son kullanıcıya giden interface’ler altında yapılması tavsiye edilen ayardır.

[Switch]interface GigabitEthernet 1/0/1

[KAT1-A-GigabitEthernet1/0/1]stp edged-port : komutu ile portun altına girilerek bu ayar tanımlanır. Bu komut sayesinde bu portlardan gelebilecek STP TC paketleri dikkate alınmaz.

LLDP Ayarları:

lldp global enable : lldp protokolünün globalde çalıştırılmasını sağlar.

lldp compliance cdp : lldp protokülün cdp ile uyumlu sağlamasını sağlar

SSH Ayarları:

ssh server enable

public-key local create rsa : SSH şifreli trafiği için bir key oluşturur.

user-interface vty 0 63

  authentication-mode scheme

  protocol inbound ssh

  exit

local-user KULLANICI-ADI

  password simple SIFRE

  service-type ssh

  authorization-attribute user-role network-admin

  exit

undo telnet server enable : son olarak telneti kapatmayı unutmayın.

POE ayarları:

[Switch]poe enable pse 4 : Global’de POE açan komuttur. Bu komut Version 7.1.045  Release 1309P02 altı firmwarelerde bulunur. 1309P03 versiyonunda Globalde POE açık gelir. Sadece interface altında açmak yeterlidir. Fakat diğer versiyonlarda interface altında poe açtıktan sonra globalde de POE açmak gereklidir. İnterface altında poe açmak için kullanılan komut aşağıdaki gibidir:

[Switch]interface GigabitEthernet 1/0/1

[Switch-GigabitEthernet1/0/1]poe enable

LACP – Aggregation Ayarları:

Öncelikle LACP çalıştırılması istenen portların atanacağı bir bridge-aggregation sanal arayüzü oluşturulur. Bu sanal arayüz Cisco IOS deki port channel’a karşılık gelir.

[Switch]interface Bridge-Aggregation 1   : 1 numaralı bridge-agg arayüzünü oluşturur. Her LACP grubu için farklı numaralı bridge-agg oluşturmalısınız.

[Switch-Bridge-Aggregation1]link-aggregation mode dynamic : LACP modunu belirler. Herhangi bir şey yazmazsanız static LACP olur.

LACP çalışmasını istediğiniz portlarda yapılması gereken VLAN (Access, trunk, hybrid vb.) ayarları LACP devreye alındıktan sonra artık bridge-agg arayüzü altında yapılmalıdır.

Bir interface’i bir LACP grubunun (bridge-aggregation 1) parçası yapmak için gereken komut aşağıdaki gibidir:

[Switch]interface Ten-GigabitEthernet 1/0/51

[Switch-Ten-GigabitEthernet1/0/51]port link-aggregation group 1

Static Route:

[Switch] ip route-static <hedef ip> <hedef mask> <gateway>

[Switch]ip route-static 0.0.0.0 0 10.10.171.3

[casoyalp-ad wminh=”” wmaxh=”” mminh=”” mmaxh=””]

VLAN Ayarları:

Vlan Oluşturma:

[Switch]vlan 1071 : 1071 VLAN ID’sine sahip yeni bir Vlan oluşturur.

[Switch-vlan1071]name Malazgirt : Oluşturulmuş bir Vlan’ın ismini belirlememizi sağlar

[Switch-vlan1071]description Bilisimciler : Vlan’a bir açıklama yazmak isterseniz bu komutu kullanabilirsiniz.

VLAN interface’ine IP verme:

[Switch]interface Vlan-interface 171  : ID’si 171 olan VLAN’a ip atamak için içine girin.

[Switch-A-Vlan-interface171]ip address 10.10.171.11 255.255.255.0  : ip adres – maske belirtin.

Portlara (interface) VLAN atama ayarları:

Comware işletim sistemli switchlerde interface altında 3 tip link modu bulunur bunlar:

Access: Cisco IOS’de Access, Extreme networks EXOS’da untagged ayarı ile aynıdır. Port altına tek bir vlan atanacağı zaman kullanılabilir.

Trunk: Cisco IOS’de trunk, Extreme networks EXOS’da tagged ayarı ile aynıdır. Birden çok vlanı Uplinklerle veya sunucularla haberleştirebilmek için kullanılır. Trunk PVID komutu ile trunk porttan bir adet untagged vlan geçirilebilir.

Hybrid: Port altında hem Access hem trunk (tagged – untagged) vlan ataması yapmak için kullanılır.

Vlan tipini belirtmek için, interface altına girin:

Access:

[Switch]interface Ten-GigabitEthernet 1/0/51

[Switch-Ten-GigabitEthernet1/0/51]port link-type access

[KAT1-A-GigabitEthernet1/0/51]port access vlan 171

Trunk:

[Switch]interface Ten-GigabitEthernet 1/0/51

[Switch-Ten-GigabitEthernet1/0/51]port link-type trunk

[Switch-Ten-GigabitEthernet1/0/51]undo port trunk permit vlan 1 : ID’si 1 olan Vlanın porttan geçmemesi için yapılan ayardır.

[Switch-Ten-GigabitEthernet1/0/51]port trunk permit vlan 4 7 150 : 4, 7 ve 150 ID’li Vlanların porttan trunk olarak geçmesine izin vermek için yapılan ayardır.

[Switch-Ten-GigabitEthernet1/0/51]port trunk pvid vlan 144 : trunk portun altında ID’si 144 olan vlanın tagsiz (untagged) olarak geçmesini sağlayan komuttur.

Hybrid:

[Switch]interface Ten-GigabitEthernet 1/0/51

[Switch-Ten-GigabitEthernet1/0/51]port link-type hybrid

 [Switch-Ten-GigabitEthernet1/0/51] undo port hybrid vlan 1 : vlan 1’in tagli/tagsiz porttan geçmemesi için yapılan ayardır.

[Switch-Ten-GigabitEthernet1/0/51] port hybrid vlan 150 tagged : 150 ID’li Vlanın porttan tagli ( tagged ) olarak geçmesine izin vermek için yapılan ayardır.

[Switch-Ten-GigabitEthernet1/0/51] port hybrid vlan 4 untagged : 4 ID’li Vlanın porttan tagsiz ( untagged ) olarak geçmesine izin vermek için yapılan ayardır.

[Switch-Ten-GigabitEthernet1/0/51] port hybrid pvid vlan 4 : 4 ID’li Vlanın son kullanıcı tarafından erişilebilmesi için ayarlanması gereken komuttur

Voice VLAN komutları:

[Switch-Ten-GigabitEthernet1/0/1] voice-vlan qos trust : ses trafiğini önceliklendirmek için kullanılan komuttur

[Switch-Ten-GigabitEthernet1/0/1] undo voice-vlan mode auto : otomatik ses vlanı atamasını devre dışı bırakır.

[Switch-Ten-GigabitEthernet1/0/1] voice-vlan 150 enable : 150 ID’li Vlan’ı voice vlanı olarak belirtmenizi sağlar.

 

İşe yarayabilir:

<Switch>display current-configuration komutu ile mevcut ayarları inceleyebilirsiniz.

<Switch>display current-configuration | include ntp : içerisinde ntp geçen komut satırlarını filtreleyerek önünüze getirir.

<Switch>display current-configuration | begin ntp : ilk ntp kelimesi geçen satırdan başlayıp ayarların sonuna kadar olan bölümü  filtreleyerek önünüze getirir.

 

[Switch-Ten-GigabitEthernet1/0/51] default : bir portun altındaki ayarları tamamen sıfırlamak, başa döndürmek isterseniz “default” komutunu kullanabilirsiniz.

<Switch>write &<Switch>save : bu iki komutu da yaptığınız ayarların kaydedilmesi için kullanabilirsiniz.

<Switch>reboot : switch’i yeniden başlatmak için kullanabilirsiniz.

<Switch> reset saved-config : switch’te varolan tüm ayarları sıfırlamak için kullanılır.

Comware 5130 ile ilgili olabilecek diğer yazıları görmek için buraya tıklayabilirsin.

[casoyalp-ad wminh=”” wmaxh=”” mminh=”” mmaxh=””]

[casoyalp-ad wminh=”” wmaxh=”” mminh=”” mmaxh=””]

Port Mirror (monitor) Ayarı:

[Comware]mirroring-group 1 local

[Comware]mirroring-group 1 mirroring-port g1/0/6 both : g1/0/6 interface’i 1 numaralı mirror işlemi için kaynak olarak seçilmiş hem inbound hem outbound (both) paketler dahil edilmiş

[Comware]mirroring-group 1 monitor-port g1/0/4 : 1 numaralı mirror işlemi için paketlerin yönlendirileceği hedef portu g1/0/4

Bir yanıt yazın

E-posta adresiniz yayınlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir